American Express cards not working
Incident Report for Npay
Resolved
This incident has been resolved.
Posted Sep 08, 2017 - 11:18 EEST
Monitoring
Fix deployed, American Express authorizations should work normally again. Monitoring the situation.
Posted Sep 08, 2017 - 10:43 EEST
Identified
Problem has been located in a change of certificate authority. Fix underway and will be deployed within 15 minutes.
Posted Sep 08, 2017 - 10:24 EEST
Investigating
American Express connections are having a problem and no authorizations are getting through.
Posted Sep 08, 2017 - 10:20 EEST