Telia network connection issues
Incident Report for Npay
Postmortem

A nationwide issue at a major ISP caused outages for many service vendors across Finland and affected both mobile and wired connections. The only way for a merchant to stay online over this kind of incident would be to have internet connections from more than one ISP.

https://www.hs.fi/kotimaa/art-2000006487834.html

https://yle.fi/uutiset/3-11323265

What we can do better on this kind of incident is to get the information to you quicker - we’ll be improving that going forward

Posted Apr 26, 2020 - 21:17 EEST

Resolved
According to Telia, issue was resolved at 19:00 EET.
Posted Apr 25, 2020 - 20:02 EEST
Monitoring
Confirmed - Telia has a nationwide network connectivity issue affecting both their mobile and wired network connections - try to get connected via another ISP if experiencing issues.

https://www.telia.fi/asiakastuki/hairiotiedote?id=sabre_187244176&lang=fi

We will monitor the situation until Telia side is resolved.
Posted Apr 25, 2020 - 14:42 EEST
Update
The issue appears to be specific to Telia but not to 3G. We have seen reports that some Telia connections are down. If possible, try to get connected via another ISP.
Posted Apr 25, 2020 - 13:22 EEST
Investigating
On Saturday 2020-04-25 at 12:15 EET some payment terminals lost connection to our service. This appears to be a 3G issue in Telia network. We are investigating.
Posted Apr 25, 2020 - 13:07 EEST
This incident affected: Cellular payment terminal connections (Telia (Worldline Yomani and Yoximo terminals)).