Amex authorizations
Incident Report for Poplatek
Resolved
Problem with Amex has been resolved.
Posted Jul 01, 2021 - 09:36 EEST
Identified
Amex authorizations are not available at the moment, we are fixing the issue
Posted Jul 01, 2021 - 08:05 EEST
This incident affected: Acquirer Connections (American Express).