Problem affecting transaction reports on the terminals
Incident Report for Poplatek
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 14:11 EEST
Investigating
We are currently investigating this issue affecting transaction reports on the terminals. We recommend using the reports in Poplaypay Online Tools until this issue has been resolved.
Posted Aug 12, 2022 - 12:49 EEST
This incident affected: Poplapay online tools.