Poplapay Online Tools and terminal sales report transaction data is delayed
Incident Report for Poplatek
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 19:07 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2020 - 18:58 EEST
Update
We are continuing to investigate this issue.
Posted Aug 24, 2020 - 18:50 EEST
Investigating
We are currently investigating the issue
Posted Aug 24, 2020 - 18:50 EEST
This incident affected: Poplapay online tools.