Problems with our support phone number
Incident Report for Poplatek
Resolved
This incident has been resolved.
Posted Apr 11, 2022 - 09:05 EEST
Investigating
We are currently investigating the issue. Until the problem is resolved, please contact us by e-mail on support@poplapay.com.
Posted Apr 05, 2022 - 12:44 EEST